月度归档:2014年04月

libvirt升级错误记录

错误提示:
> *ImportError: /usr/local/lib/libvirt.so.0: version `LIBVIRT_PRIVATE_0.10.2′
> not found (required by /usr/lib/python2.6/site-packages/libvirtmod.so)*
产生背景:
libvirt-1.2.3编译安装结束后,运行virt-install时产生的错误提示信息
解决方案:
参考https://www.redhat.com/archives/libvirt-users/2013-September/msg00197.html,
http://libvirt.org/compiling.html
编译之前运行./autogen.sh –system,使得编译安装的libvirt覆盖centos发行版中默认的libvirt